Vulnerability · Published Nov 4, 2022 · Assigned by GitHub_M
CVE-2022-39387XWiki OIDC Authenticator vulnerable to OpenID login bypass due to improper authentication
Critical 9.1
In plain English
A critical-severity improper authentication in oidc from xwiki-contrib. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
XWiki OIDC has various tools to manipulate OpenID Connect protocol in XWiki. Prior to version 1.29.1, even if a wiki has an OpenID provider configured through its xwiki.properties, it is possible to provide a third party provider its details through request parameters. One can then bypass the XWiki authentication altogether by specifying its own provider through the oidc.endpoint.* request parameters (or by using an XWiki-based OpenID provider with oidc.xwikiprovider. With the same approach, one could also provide a specific group mapping through oidc.groups.mapping that would make his user automatically part of the XWikiAdminGroup. This issue has been patched, please upgrade to 1.29.1. There is no workaround, an upgrade of the authenticator is required.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.xwiki.contrib.oidc:oidc-authenticator | 1.29.1 | GHSA-m7gv-v8xx-v47w |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| xwiki-contrib | oidc | < 1.29.1 |
Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H