Vulnerability · Published Nov 4, 2022 · Assigned by GitHub_M
CVE-2022-39384OpenZeppelin Contracts initializer reentrancy may lead to double initialization
Medium 5.6
In plain English
A medium-severity security flaw in openzeppelin-contracts from OpenZeppelin. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OpenZeppelin Contracts is a library for secure smart contract development. Before version 4.4.1 but after 3.2.0, initializer functions that are invoked separate from contract creation (the most prominent example being minimal proxies) may be reentered if they make an untrusted non-view external call. Once an initializer has finished running it can never be re-executed. However, an exception put in place to support multiple inheritance made reentrancy possible in the scenario described above, breaking the expectation that there is a single execution. Note that upgradeable proxies are commonly initialized together with contract creation, where reentrancy is not feasible, so the impact of this issue is believed to be minor. This issue has been patched, please upgrade to version 4.4.1. As a workaround, avoid untrusted external calls during initialization.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @openzeppelin/contracts | 4.4.1 | GHSA-88g8-f5mf-f5rj |
| npm | @openzeppelin/contracts | 4.4.1 | GHSA-9c22-pwxw-p6hx |
| npm | @openzeppelin/contracts-upgradeable | 4.4.1 | GHSA-9c22-pwxw-p6hx |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenZeppelin | openzeppelin-contracts | >= 3.2.0, < 4.4.1 |
Weakness: CWE-665 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L