Vulnerability · Published Nov 8, 2022 · Assigned by GitHub_M

CVE-2022-39352OpenFGA Authorization Bypass

Medium 4.8

In plain English

A medium-severity incorrect authorization in openfga from openfga. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.8Medium
Exploit odds (30 days)0.5%top 56.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

OpenFGA is a high-performance authorization/permission engine inspired by Google Zanzibar. Versions prior to 0.2.5 are vulnerable to authorization bypass under certain conditions. You are affected by this vulnerability if you added a tuple with a wildcard (*) assigned to a tupleset relation (the right hand side of a ‘from’ statement). This issue has been patched in version v0.2.5. This update is not backward compatible with any authorization model that uses wildcard on a tupleset relation.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/openfga/openfga0.2.5GO-2022-1099
Gogithub.com/openfga/openfga0.2.5GHSA-3gfj-fxx4-f22w

Affected products (as reported)

VendorProductVersions
openfga openfga < 0.2.5

Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

References