Vulnerability · Published Oct 24, 2022 · Assigned by GitHub_M
CVE-2022-39313Parse Server crashes when receiving file download request with invalid byte range
High 7.5
In plain English
A high-severity security flaw in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Versions prior to 4.10.17, and prior to 5.2.8 on the 5.x branch, crash when a file download request is received with an invalid byte range, resulting in a Denial of Service. This issue has been patched in versions 4.10.17, and 5.2.8. There are no known workarounds.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | parse-server | 4.10.17 | GHSA-h423-w6qv-2wj3 |
| npm | parse-server | 5.2.8 | GHSA-h423-w6qv-2wj3 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| parse-community | parse-server | < 4.10.17>= 5.0.0, < 5.2.8 |
Weakness: CWE-1284 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H