Vulnerability · Published Oct 12, 2022 · Assigned by GitHub_M
CVE-2022-39299Signature bypass via multiple root elements in Passport-SAML
High 7.4
In plain English
A high-severity security flaw in passport-saml from node-saml. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 4.5% (higher than 92% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Users should upgrade to passport-saml version 3.2.2 or newer. The issue was also present in the beta releases of `node-saml` before version 4.0.0-beta.5. If you cannot upgrade, disabling SAML authentication may be done as a workaround.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @node-saml/node-saml | 4.0.0-beta.5 | GHSA-m974-647v-whv7 |
| npm | @node-saml/passport-saml | 4.0.0-beta.3 | GHSA-m974-647v-whv7 |
| npm | node-saml | 4.0.0-beta.5 | GHSA-m974-647v-whv7 |
| npm | passport-saml | 3.2.2 | GHSA-m974-647v-whv7 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| node-saml | passport-saml | < 3.2.2 |
Weakness: CWE-347 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N