Vulnerability · Published Sep 23, 2022 · Assigned by GitHub_M

CVE-2022-39225Parse Server subject to Incorrect Resource Transfer Between Spheres

Medium 4.3

In plain English

A medium-severity security flaw in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.5%top 57.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 4.10.15, or 5.0.0 and above prior to 5.2.6, a user can write to the session object of another user if the session object ID is known. For example, an attacker can assign the session object to their own user by writing to the `user` field and then read any custom fields of that session object. Note that assigning a session to another user does not usually change the privileges of either of the two users, and a user cannot assign their own session to another user. This issue is patched in version 4.10.15 and above, and 5.2.6 and above. To mitigate this issue in unpatched versions add a `beforeSave` trigger to the `_Session` class and prevent writing if the requesting user is different from the user in the session object.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmparse-server4.10.15GHSA-6w4q-23cf-j9jp
npmparse-server5.2.6GHSA-6w4q-23cf-j9jp

Affected products (as reported)

VendorProductVersions
parse-community parse-server < 4.10.15>= 5.0.0, < 5.2.6

Weakness: CWE-669 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

References