Vulnerability · Published Sep 16, 2022 · Assigned by GitHub_M
CVE-2022-39211Server-Side Request Forgery (SSRF) via potential filter bypass in Nextcloud Server
Low 3.0
In plain English
A low-severity server-side request forgery in security-advisories from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities).
Official description
Nextcloud server is an open source personal cloud platform. In affected versions it was found that locally running webservices can be found and requested erroneously. It is recommended that the Nextcloud Server is upgraded to 23.0.8 or 24.0.4. It is recommended that the Nextcloud Enterprise Server is upgraded to 22.2.10.4, 23.0.8 or 24.0.4. There are no known workarounds for this issue.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | security-advisories | < 23.0.8>= 24.0.0, < 24.0.4 |
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-rmf9-w497-8cq8 x_refsource_CONFIRM
- https://github.com/nextcloud/server/pull/32988 x_refsource_MISC
- https://github.com/nextcloud/server/pull/33031 x_refsource_MISC