Vulnerability · Published Aug 31, 2022 · Assigned by apache
CVE-2022-37023Apache Geode deserialization of untrusted data flaw when using REST API on Java 8 or Java 11
Medium 6.5
In plain English
A medium-severity unsafe deserialization in Apache Geode from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.8% (higher than 78% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. Any user wishing to protect against deserialization attacks involving REST APIs should upgrade to Apache Geode 1.15 and follow the documentation for details on enabling "validate-serializable-objects=true" and specifying any user classes that may be serialized/deserialized with "serializable-object-filter". Enabling "validate-serializable-objects" may impact performance.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.geode:geode-core | 1.15.0 | GHSA-72x9-48mc-phh6 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Geode | Apache Geode – before 1.15.0 |
Weakness: CWE-502
References
- https://lists.apache.org/thread/6js89pbqrp52zlpwgry5fsdn76gxbbfj x_refsource_MISC