Vulnerability · Published Nov 23, 2022 · Assigned by GitHub_M
CVE-2022-36111immundb has insufficient verification of data authenticity
Medium 5.4
In plain English
A medium-severity insufficient verification of data authenticity in immudb from codenotary. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
immudb is a database with built-in cryptographic proof and verification. In versions prior to 1.4.1, a malicious immudb server can provide a falsified proof that will be accepted by the client SDK signing a falsified transaction replacing the genuine one. This situation can not be triggered by a genuine immudb server and requires the client to perform a specific list of verified operations resulting in acceptance of an invalid state value. This vulnerability only affects immudb client SDKs, the immudb server itself is not affected by this vulnerability. This issue has been patched in version 1.4.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/codenotary/immudb | 1.4.1 | GHSA-672p-m5jq-mrh8 |
| Go | github.com/codenotary/immudb | 1.4.1 | GO-2022-1117 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| codenotary | immudb | < 1.4.1 |
Weakness: CWE-345 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:N/I:H/A:N