Vulnerability · Published Sep 9, 2022 · Assigned by GitHub_M

CVE-2022-36109Moby vulnerability relating to supplementary group permissions

Medium 5.3

In plain English

A medium-severity incorrect authorization in moby from moby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)1.1%top 35.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Moby is an open-source project created by Docker to enable software containerization. A bug was found in Moby (Docker Engine) where supplementary groups are not set up properly. If an attacker has direct access to a container and manipulates their supplementary group access, they may be able to use supplementary group access to bypass primary group restrictions in some cases, potentially gaining access to sensitive information or gaining the ability to execute code in that container. This bug is fixed in Moby (Docker Engine) 20.10.18. Running containers should be stopped and restarted for the permissions to be fixed. For users unable to upgrade, this problem can be worked around by not using the `"USER $USERNAME"` Dockerfile instruction. Instead by calling `ENTRYPOINT ["su", "-", "user"]` the supplementary groups will be set up properly.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20docker20.10.18-r0ALPINE-CVE-2022-36109
Alpine:v3.21docker20.10.18-r0ALPINE-CVE-2022-36109
Alpine:v3.22docker20.10.18-r0ALPINE-CVE-2022-36109
Alpine:v3.23docker20.10.18-r0ALPINE-CVE-2022-36109
Alpine:v3.24docker20.10.18-r0ALPINE-CVE-2022-36109
Debian:12docker.io20.10.19+dfsg1-1DEBIAN-CVE-2022-36109
Debian:13docker.io20.10.19+dfsg1-1DEBIAN-CVE-2022-36109
Debian:14docker.io20.10.19+dfsg1-1DEBIAN-CVE-2022-36109
Gogithub.com/docker/docker20.10.18GHSA-rc4r-wh2q-q6c4
Gogithub.com/docker/docker20.10.18+incompatibleGO-2022-0985
Ubuntu:22.04:LTSdocker.io20.10.21-0ubuntu1~22.04.2UBUNTU-CVE-2022-36109

Affected products (as reported)

VendorProductVersions
moby moby < 20.10.18

Weakness: CWE-863 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

References