Vulnerability · Published Sep 13, 2022 · Assigned by GitHub_M

CVE-2022-36108Cross-Site Scripting in typo3/cms-core

Medium 6.5

In plain English

A medium-severity cross-site scripting in typo3 from TYPO3. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.9%top 39.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

TYPO3 is an open source PHP based web content management system released under the GNU GPL. It has been discovered that the `f:asset.css` view helper is vulnerable to cross-site scripting when user input is passed as variables to the CSS. Update to TYPO3 version 10.4.32 or 11.5.16 that fix the problem. There are no known workarounds for this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagisttypo3/cms10.4.32GHSA-fv2m-9249-qx85
Packagisttypo3/cms11.5.16GHSA-fv2m-9249-qx85
Packagisttypo3/cms-core10.4.32GHSA-fv2m-9249-qx85
Packagisttypo3/cms-core11.5.16GHSA-fv2m-9249-qx85

Affected products (as reported)

VendorProductVersions
TYPO3 typo3 >= 10.3.0, < 10.4.32>= 11.0.0, < 11.5.16

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L

References