Vulnerability · Published Jan 20, 2023 · Assigned by GitHub_M

CVE-2022-35977Integer overflow in certain command arguments can drive Redis to OOM panic

Medium 5.5

In plain English

A medium-severity integer overflow in redis from redis. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 14.0% (higher than 97% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.5Medium
Exploit odds (30 days)14.0%top 3.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Redis is an in-memory database that persists on disk. Authenticated users issuing specially crafted `SETRANGE` and `SORT(_RO)` commands can trigger an integer overflow, resulting with Redis attempting to allocate impossible amounts of memory and abort with an out-of-memory (OOM) panic. The problem is fixed in Redis versions 7.0.8, 6.2.9 and 6.0.17. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8redis6.2.17-1.module_el8.10.0+3946+3de613d5ALSA-2025:0595
AlmaLinux:8redis-devel6.2.17-1.module_el8.10.0+3946+3de613d5ALSA-2025:0595
AlmaLinux:8redis-doc6.2.17-1.module_el8.10.0+3946+3de613d5ALSA-2025:0595
Alpine:v3.20redis7.0.8-r0ALPINE-CVE-2022-35977
Alpine:v3.21redis7.0.8-r0ALPINE-CVE-2022-35977
Alpine:v3.22redis7.0.8-r0ALPINE-CVE-2022-35977
Alpine:v3.23redis7.0.8-r0ALPINE-CVE-2022-35977
Alpine:v3.24redis7.0.8-r0ALPINE-CVE-2022-35977
Debian:12redis5:7.0.8-1DEBIAN-CVE-2022-35977
Debian:13redis5:7.0.8-1DEBIAN-CVE-2022-35977
Debian:14redis5:7.0.8-1DEBIAN-CVE-2022-35977
Rocky Linux:8redis0:6.2.17-1.module+el8.10.0+1923+5b85c6a7RLSA-2025:0595

Affected products (as reported)

VendorProductVersions
redis redis >= 7.0, < 7.0.8>= 6.2, < 6.2.9< 6.0.17

Weakness: CWE-190 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

References