Vulnerability · Published Sep 2, 2022 · Assigned by GitHub_M
CVE-2022-35933PrestaShop module Product Comments vulnerable to cross-site scripting (XSS)
Medium 4.3
In plain English
A medium-severity cross-site scripting in productcomments from PrestaShop. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.0)4.3Medium
Exploit odds (30 days)0.6%top 53.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
This package is a PrestaShop module that allows users to post reviews and rate products. There is a vulnerability where the attacker could steal an administrator's cookie. The issue is fixed in version 5.0.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | prestashop/productcomments | 5.0.2 | GHSA-prrh-qvhf-x788 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| PrestaShop | productcomments | < 5.0.2 |
Weakness: CWE-79 · Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N