Vulnerability · Published Aug 2, 2022 · Assigned by GitHub_M
CVE-2022-35925Missing rate limit in Authentication in bookwyrm
Medium 5.3
In plain English
A medium-severity improper authentication in bookwyrm from bookwyrm-social. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.8% (higher than 78% of all known vulnerabilities).
Official description
BookWyrm is a social network for tracking reading. Versions prior to 0.4.5 were found to lack rate limiting on authentication views which allows brute-force attacks. This issue has been patched in version 0.4.5. Admins with existing instances will need to update their `nginx.conf` file that was created when the instance was set up. Users are advised advised to upgrade. Users unable to upgrade may update their nginx.conf files with the changes manually.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| bookwyrm-social | bookwyrm | < 0.4.5 |
Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L