Vulnerability · Published Aug 1, 2022 · Assigned by GitHub_M
CVE-2022-35916Cross chain utilities for Arbitrum L2 see EOA calls as cross chain calls
Medium 5.3
In plain English
A medium-severity security flaw in openzeppelin-contracts from OpenZeppelin. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OpenZeppelin Contracts is a library for secure smart contract development. Contracts using the cross chain utilities for Arbitrum L2, `CrossChainEnabledArbitrumL2` or `LibArbitrumL2`, will classify direct interactions of externally owned accounts (EOAs) as cross chain calls, even though they are not started on L1. This issue has been patched in v4.7.2. Users are advised to upgrade. There are no known workarounds for this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @openzeppelin/contracts | 4.7.2 | GHSA-9j3m-g383-29qr |
| npm | @openzeppelin/contracts-upgradeable | 4.7.2 | GHSA-9j3m-g383-29qr |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenZeppelin | openzeppelin-contracts | >= 4.6.0, < 4.7.2 |
Weakness: CWE-669 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N