Vulnerability · Published Aug 1, 2022 · Assigned by GitHub_M
CVE-2022-35915Unbounded gas consumption in @openzeppelin/contracts
Medium 5.3
In plain English
A medium-severity uncontrolled resource consumption in openzeppelin-contracts from OpenZeppelin. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OpenZeppelin Contracts is a library for secure smart contract development. The target contract of an EIP-165 `supportsInterface` query can cause unbounded gas consumption by returning a lot of data, while it is generally assumed that this operation has a bounded cost. The issue has been fixed in v4.7.2. Users are advised to upgrade. There are no known workarounds for this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @openzeppelin/contracts | 4.7.2 | GHSA-7grf-83vw-6f5x |
| npm | @openzeppelin/contracts-upgradeable | 4.7.2 | GHSA-7grf-83vw-6f5x |
| npm | openzeppelin-eth | no fix listed | GHSA-7grf-83vw-6f5x |
| npm | openzeppelin-solidity | no fix listed | GHSA-7grf-83vw-6f5x |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenZeppelin | openzeppelin-contracts | >=2.0.0 < 4.7.2 |
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L