Vulnerability · Published Jul 6, 2022 · Assigned by apache

CVE-2022-33980Apache Commons Configuration insecure interpolation defaults

Critical 9.8

In plain English

A critical-severity security flaw in Apache Commons Configuration from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 44.6% (higher than 99% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)44.6%top 1.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling1Public PoC

Official description

Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12commons-configuration22.8.0-1DEBIAN-CVE-2022-33980
Debian:13commons-configuration22.8.0-1DEBIAN-CVE-2022-33980
Debian:14commons-configuration22.8.0-1DEBIAN-CVE-2022-33980
Mavenorg.apache.commons:commons-configuration22.8.0GHSA-xj57-8qj4-c4m6
Ubuntu:22.04:LTScommons-configuration2no fix listedUBUNTU-CVE-2022-33980

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Commons Configuration Apache Commons Configuration – before 2.8.0

References