Vulnerability · Published Jul 14, 2022 · Assigned by hackerone

CVE-2022-32210

Medium 6.5

In plain English

A medium-severity improper certificate validation in https://github.com/nodejs/undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)6.5Medium
Exploit odds (30 days)0.5%top 59.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

`Undici.ProxyAgent` never verifies the remote server's certificate, and always exposes all request & response data to the proxy. This unexpectedly means that proxies can MitM all HTTPS traffic, and if the proxy's URL is HTTP then it also means that nominally HTTPS requests are actually sent via plain-text HTTP between Undici and the proxy server.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-undici5.6.1+dfsg1+~cs18.9.16-1DEBIAN-CVE-2022-32210
Debian:13node-undici5.6.1+dfsg1+~cs18.9.16-1DEBIAN-CVE-2022-32210
Debian:14node-undici5.6.1+dfsg1+~cs18.9.16-1DEBIAN-CVE-2022-32210
npmundici5.5.1GHSA-pgw7-wx7w-2w33

Affected products (as reported)

VendorProductVersions
n/a https://github.com/nodejs/undici Fixed in version >= v5.5.1. Vulnerable between v4.8.2 and v5.5.0

Weakness: CWE-295

References