Vulnerability · Published Aug 1, 2022 · Assigned by GitHub_M
CVE-2022-31186Leakage of excessive information into log in next-auth
Low 3.3
In plain English
A low-severity sensitive data in logs in next-auth from nextauthjs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
NextAuth.js is a complete open source authentication solution for Next.js applications. An information disclosure vulnerability in `next-auth` before `v4.10.2` and `v3.29.9` allows an attacker with log access privilege to obtain excessive information such as an identity provider's secret in the log (which is thrown during OAuth error handling) and use it to leverage further attacks on the system, like impersonating the client to ask for extensive permissions. This issue has been patched in `v4.10.2` and `v3.29.9` by moving the log for `provider` information to the debug level. In addition, we added a warning for having the `debug: true` option turned on in production. If for some reason you cannot upgrade, you can user the `logger` configuration option by sanitizing the logs.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | next-auth | 3.29.9 | GHSA-p6mm-27gq-9v3p |
| npm | next-auth | 4.10.2 | GHSA-p6mm-27gq-9v3p |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextauthjs | next-auth | >= 4.0.0, < 4.10.2< 3.29.9 |
Weakness: CWE-532 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
References
- https://next-auth.js.org/getting-started/upgrade-v4 x_refsource_MISC
- https://github.com/nextauthjs/next-auth/security/advisories/GHSA-p6mm-27gq-9v3p x_refsource_CONFIRM
- https://next-auth.js.org/configuration/options#logger x_refsource_MISC
- https://next-auth.js.org/warnings#debug_enabled x_refsource_MISC