Vulnerability · Published Jul 20, 2022 · Assigned by GitHub_M

CVE-2022-31160jQuery UI contains potential XSS vulnerability when refreshing a checkboxradio with an HTML-like initial text label

Medium 6.1

In plain English

A medium-severity cross-site scripting in jquery-ui from jquery. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 2.7% (higher than 86% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)2.7%top 14.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling1Public PoC

Official description

jQuery UI is a curated set of user interface interactions, effects, widgets, and themes built on top of jQuery. Versions prior to 1.13.2 are potentially vulnerable to cross-site scripting. Initializing a checkboxradio widget on an input enclosed within a label makes that parent label contents considered as the input label. Calling `.checkboxradio( "refresh" )` on such a widget and the initial HTML contained encoded HTML entities will make them erroneously get decoded. This can lead to potentially executing JavaScript code. The bug has been patched in jQuery UI 1.13.2. To remediate the issue, someone who can change the initial HTML can wrap all the non-input contents of the `label` in a `span`.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12jqueryui1.13.2+dfsg-1DEBIAN-CVE-2022-31160
Debian:13jqueryui1.13.2+dfsg-1DEBIAN-CVE-2022-31160
Debian:14jqueryui1.13.2+dfsg-1DEBIAN-CVE-2022-31160
Mavenorg.webjars.npm:jquery-ui1.13.2GHSA-h6gj-6jjq-h8g9
NuGetjquery.ui.combined1.13.2GHSA-h6gj-6jjq-h8g9
RubyGemsjquery-ui-rails8.0.0GHSA-h6gj-6jjq-h8g9
npmjquery-ui1.13.2GHSA-h6gj-6jjq-h8g9

Affected products (as reported)

VendorProductVersions
jquery jquery-ui < 1.13.2

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References