Vulnerability · Published Jul 6, 2022 · Assigned by GitHub_M

CVE-2022-31124Possible leak of key's raw field if declared length is incorrect in openssh_key_parser

High 7.7

In plain English

A high-severity security flaw in openssh_key_parser from scottcwang. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 71% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.7High
Exploit odds (30 days)1.3%top 28.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

openssh_key_parser is an open source Python package providing utilities to parse and pack OpenSSH private and public key files. In versions prior to 0.0.6 if a field of a key is shorter than it is declared to be, the parser raises an error with a message containing the raw field value. An attacker able to modify the declared length of a key's sensitive field can thus expose the raw value of that field. Users are advised to upgrade to version 0.0.6, which no longer includes the raw field value in the error message. There are no known workarounds for this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIopenssh-key-parser0.0.6GHSA-hm37-9xh2-q499
PyPIopenssh-key-parser0.0.6PYSEC-2022-233

Affected products (as reported)

VendorProductVersions
scottcwang openssh_key_parser < 0.0.6

Weakness: CWE-209 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

References