Vulnerability · Published Jul 7, 2022 · Assigned by GitHub_M

CVE-2022-31121Improper Input Validation in fabric hyperledger

High 7.5

In plain English

A high-severity improper input validation in fabric from hyperledger. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.1% (higher than 82% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)2.1%top 17.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Hyperledger Fabric is a permissioned distributed ledger framework. In affected versions if a consensus client sends a malformed consensus request to an orderer it may crash the orderer node. A fix has been added in commit 0f1835949 which checks for missing consensus messages and returns an error to the consensus client should the message be missing. Users are advised to upgrade to versions 2.2.7 or v2.4.5. There are no known workarounds for this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/hyperledger/fabric2.2.7GHSA-72x4-cq6r-jp4p
Gogithub.com/hyperledger/fabric2.4.5GHSA-72x4-cq6r-jp4p

Affected products (as reported)

VendorProductVersions
hyperledger fabric < 2.2.7>= 2.3.0, < 2.4.5

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References