Vulnerability · Published Jun 27, 2022 · Assigned by GitHub_M
CVE-2022-31086Incorrect Regular Expressions in ldap-account-manager
Medium 6.6
In plain English
A medium-severity injection in lam from LDAPAccountManager. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.3% (higher than 83% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
LDAP Account Manager (LAM) is a webfrontend for managing entries (e.g. users, groups, DHCP settings) stored in an LDAP directory. In versions prior to 8.0 incorrect regular expressions allow to upload PHP scripts to config/templates/pdf. This vulnerability could lead to a Remote Code Execution if the /config/templates/pdf/ directory is accessible for remote users. This is not a default configuration of LAM. This issue has been fixed in version 8.0. There are no known workarounds for this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | ldap-account-manager | 8.0.1-1 | DEBIAN-CVE-2022-31086 |
| Debian:13 | ldap-account-manager | 8.0.1-1 | DEBIAN-CVE-2022-31086 |
| Debian:14 | ldap-account-manager | 8.0.1-1 | DEBIAN-CVE-2022-31086 |
| Ubuntu:22.04:LTS | ldap-account-manager | no fix listed | UBUNTU-CVE-2022-31086 |
| Ubuntu:25.10 | ldap-account-manager | no fix listed | UBUNTU-CVE-2022-31086 |
| Ubuntu:26.04:LTS | ldap-account-manager | no fix listed | UBUNTU-CVE-2022-31086 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| LDAPAccountManager | lam | < 8.0 |
Weakness: CWE-74 · Vector: CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/LDAPAccountManager/lam/commit/f1d5d04952f39a1b4ea203d3964fa88e1429dfd4 x_refsource_MISC
- https://github.com/LDAPAccountManager/lam/security/advisories/GHSA-q9pc-x84w-982x x_refsource_CONFIRM
- DSA-5177 vendor-advisory, x_refsource_DEBIAN