Vulnerability · Published Jun 27, 2022 · Assigned by GitHub_M
CVE-2022-31082SQL Injection via package deployment tasks in glpi-inventory-plugin
Medium 5.8
In plain English
A medium-severity SQL injection in glpi-inventory-plugin from glpi-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 64% of all known vulnerabilities).
Official description
GLPI is a Free Asset and IT Management Software package, Data center management, ITIL Service Desk, licenses tracking and software auditing. glpi-inventory-plugin is a plugin for GLPI to handle inventory management. In affected versions a SQL injection can be made using package deployment tasks. This issue has been resolved in version 1.0.2. Users are advised to upgrade. Users unable to upgrade should delete the `front/deploypackage.public.php` file if they are not using the `deploy tasks` feature.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| glpi-project | glpi-inventory-plugin | < 1.0.2 |
Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:N/A:N