Vulnerability · Published Jun 14, 2022 · Assigned by GitHub_M
CVE-2022-31059Discourse Calendar Event names susceptible to Cross-site Scripting
Medium 6.5
In plain English
A medium-severity cross-site scripting in discourse-calendar from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities).
Official description
Discourse Calendar is a calendar plugin for Discourse, an open-source messaging app. Prior to version 1.0.1, parsing and rendering of Event names can be susceptible to cross-site scripting (XSS) attacks. This vulnerability only affects sites which have modified or disabled Discourse’s default Content Security Policy. This issue is patched in version 1.0.1 of the Discourse Calendar plugin. As a workaround, ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| discourse | discourse-calendar | < 1.0.1 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N