Vulnerability · Published Jun 6, 2022 · Assigned by GitHub_M

CVE-2022-31030containerd CRI plugin: Host memory exhaustion through ExecSync

Medium 5.5

In plain English

A medium-severity uncontrolled resource consumption in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.5Medium
Exploit odds (30 days)0.4%top 67.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

containerd is an open source container runtime. A bug was found in the containerd's CRI implementation where programs inside a container can cause the containerd daemon to consume memory without bound during invocation of the `ExecSync` API. This can cause containerd to consume all available memory on the computer, denying service to other legitimate workloads. Kubernetes and crictl can both be configured to use containerd's CRI implementation; `ExecSync` may be used when running probes or when executing processes via an "exec" facility. This bug has been fixed in containerd 1.6.6 and 1.5.13. Users should update to these versions to resolve the issue. Users unable to upgrade should ensure that only trusted images and commands are used.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20containerd1.6.6-r0ALPINE-CVE-2022-31030
Alpine:v3.21containerd1.6.6-r0ALPINE-CVE-2022-31030
Alpine:v3.22containerd1.6.6-r0ALPINE-CVE-2022-31030
Alpine:v3.23containerd1.6.6-r0ALPINE-CVE-2022-31030
Alpine:v3.24containerd1.6.6-r0ALPINE-CVE-2022-31030
Debian:12containerd1.6.6~ds1-1DEBIAN-CVE-2022-31030
Debian:13containerd1.6.6~ds1-1DEBIAN-CVE-2022-31030
Debian:14containerd1.6.6~ds1-1DEBIAN-CVE-2022-31030
Gogithub.com/containerd/containerd1.6.6GHSA-5ffw-gxpp-mxpf
Gogithub.com/containerd/containerd1.5.13, 1.6.6GO-2022-0482
Gogithub.com/containerd/containerd1.5.13GHSA-5ffw-gxpp-mxpf
Ubuntu:22.04:LTScontainerd1.5.9-0ubuntu3.1UBUNTU-CVE-2022-31030
Ubuntu:22.04:LTScontainerd1.5.9-0ubuntu3.1USN-5776-1

Affected products (as reported)

VendorProductVersions
containerd containerd < 1.5.13>= 1.6.0, < 1.6.6

Weakness: CWE-400 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

References