Vulnerability · Published May 31, 2022 · Assigned by apache

CVE-2022-30973Missing fix for CVE-2022-30126 in 1.28.2

Medium 5.5

In plain English

A medium-severity security flaw in Apache Tika from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.0% (higher than 81% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)5.5Medium
Exploit odds (30 days)2.0%top 19.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

We failed to apply the fix for CVE-2022-30126 to the 1.x branch in the 1.28.2 release. In Apache Tika, a regular expression in the StandardsText class, used by the StandardsExtractingContentHandler could lead to a denial of service caused by backtracking on a specially crafted file. This only affects users who are running the StandardsExtractingContentHandler, which is a non-standard handler. This is fixed in 1.28.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.tika:tika-core1.28.3GHSA-qw3f-w4pf-jh5f
Ubuntu:24.04:LTStikano fix listedUBUNTU-CVE-2022-30973
Ubuntu:25.10tikano fix listedUBUNTU-CVE-2022-30973
Ubuntu:26.04:LTStikano fix listedUBUNTU-CVE-2022-30973
Ubuntu:26.10tikano fix listedUBUNTU-CVE-2022-30973

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tika Apache Tika – through 1.28.2

References