Vulnerability · Published May 25, 2022 · Assigned by GitHub_M

CVE-2022-29256Possible vulnerability at 'npm install' time in sharp if an attacker has control over build environment

Medium 6.5

In plain English

A medium-severity command injection in sharp from lovell. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.4%top 67.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

sharp is an application for Node.js image processing. Prior to version 0.30.5, there is a possible vulnerability in logic that is run only at `npm install` time when installing versions of `sharp` prior to the latest v0.30.5. If an attacker has the ability to set the value of the `PKG_CONFIG_PATH` environment variable in a build environment then they might be able to use this to inject an arbitrary command at `npm install` time. This is not part of any runtime code, does not affect Windows users at all, and is unlikely to affect anyone that already cares about the security of their build environment. This problem is fixed in version 0.30.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmsharp0.30.5GHSA-gp95-ppv5-3jc5

Affected products (as reported)

VendorProductVersions
lovell sharp < 0.30.5

Weakness: CWE-77 · Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H

References