Vulnerability · Published May 25, 2022 · Assigned by GitHub_M
CVE-2022-29253Path Traversal in XWiki Platform
Low 2.7
In plain English
A low-severity path traversal in xwiki-platform from xwiki. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Starting with version 8.3-rc-1 and prior to versions 12.10.3 and 14.0, one can ask for any file located in the classloader using the template API and a path with ".." in it. The issue is patched in versions 14.0 and 13.10.3. There is no easy workaround for this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.xwiki.platform:xwiki-platform-oldcore | 13.10.3 | GHSA-9qrp-h7fw-42hg |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| xwiki | xwiki-platform | >= 8.3-rc-1, < 13.10.3 |
Weakness: CWE-24, CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
References
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-9qrp-h7fw-42hg x_refsource_CONFIRM
- https://github.com/xwiki/xwiki-platform/commit/4917c8f355717bb636d763844528b1fe0f95e8e2 x_refsource_MISC
- https://jira.xwiki.org/browse/XWIKI-19349 x_refsource_MISC