Vulnerability · Published Jun 14, 2022 · Assigned by GitHub_M
CVE-2022-29241Known or guessable hidden files may be accessed in Jupyter Server
High 7.1
In plain English
A high-severity information exposure in jupyter_server from jupyter-server. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Jupyter Server provides the backend (i.e. the core services, APIs, and REST endpoints) for Jupyter web applications like Jupyter Notebook. Prior to version 1.17.1, if notebook server is started with a value of `root_dir` that contains the starting user's home directory, then the underlying REST API can be used to leak the access token assigned at start time by guessing/brute forcing the PID of the jupyter server. While this requires an authenticated user session, this URL can be used from a cross-site scripting payload or from a hooked or otherwise compromised browser to leak this access token to a malicious third party. This token can be used along with the REST API to interact with Jupyter services/notebooks such as modifying or overwriting critical files, such as .bashrc or .ssh/authorized_keys, allowing a malicious user to read potentially sensitive data and possibly gain control of the impacted system. This issue is patched in version 1.17.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | jupyter-server | 1.17.1-1 | DEBIAN-CVE-2022-29241 |
| Debian:13 | jupyter-server | 1.17.1-1 | DEBIAN-CVE-2022-29241 |
| Debian:14 | jupyter-server | 1.17.1-1 | DEBIAN-CVE-2022-29241 |
| PyPI | jupyter-server | 1.17.1 | GHSA-q874-g24w-4q9g |
| PyPI | jupyter-server | 2.0.0a1 | GHSA-q874-g24w-4q9g |
| PyPI | jupyter-server | 1.17.0 | PYSEC-2022-211 |
| Ubuntu:22.04:LTS | jupyter-server | no fix listed | UBUNTU-CVE-2022-29241 |
| Ubuntu:24.04:LTS | jupyter-server | no fix listed | UBUNTU-CVE-2022-29241 |
| Ubuntu:25.10 | jupyter-server | no fix listed | UBUNTU-CVE-2022-29241 |
| Ubuntu:26.04:LTS | jupyter-server | no fix listed | UBUNTU-CVE-2022-29241 |
| Ubuntu:26.10 | jupyter-server | no fix listed | UBUNTU-CVE-2022-29241 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jupyter-server | jupyter_server | < 1.17.1 |
Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H