Vulnerability · Published Feb 25, 2022 · Assigned by apache

CVE-2022-24947Apache JSPWiki CSRF Account Takeover

High 8.8

In plain English

A high-severity security flaw in Apache JSPWiki from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 67% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)8.8High
Exploit odds (30 days)1.2%top 32.7% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Apache JSPWiki user preferences form is vulnerable to CSRF attacks, which can lead to account takeover. Apache JSPWiki users should upgrade to 2.11.2 or later.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.jspwiki:jspwiki-main2.11.2GHSA-4284-x26r-4hhc

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache JSPWiki Apache JSPWiki up to 2.11.1

References