Vulnerability · Published Apr 20, 2022 · Assigned by GitHub_M

CVE-2022-24872Improper Access Control in shopware

High 8.1

In plain English

A high-severity incorrect permission assignment in platform from shopware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)1.1%top 35.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Shopware is an open commerce platform based on Symfony Framework and Vue. Permissions set to sales channel context by admin-api are still usable within normal user session. Users are advised to update to the current version 6.4.10.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. There are no known workarounds for this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistshopware/core6.4.10.1GHSA-9wrv-g75h-8ccc
Packagistshopware/platform6.4.10.1GHSA-9wrv-g75h-8ccc

Affected products (as reported)

VendorProductVersions
shopware platform < 6.4.10.1

Weakness: CWE-732 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

References