Vulnerability · Published Apr 6, 2022 · Assigned by GitHub_M

CVE-2022-24822Denial of Service in @podium/layout and @podium/proxy

High 7.5

In plain English

A high-severity security flaw in proxy from podium-lib. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.7% (higher than 77% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.7%top 23.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Podium is a library for building micro frontends. @podium/layout is a module for building a Podium layout server, and @podium/proxy is a module for proxying HTTP requests from a layout server to a podlet server. In @podium/layout prior to version 4.6.110 and @podium/proxy prior to version 4.2.74, an attacker using the `Trailer` header as part of the request against proxy endpoints has the ability to take down the server. All Podium layouts that include podlets with proxy endpoints are affected. `@podium/layout`, which is the main way developers/users are vulnerable to this exploit, has been patched in version `4.6.110`. All earlier versions are vulnerable.`@podium/proxy`, which is the source of the vulnerability and is used by `@podium/layout` has been patched in version `4.2.74`. All earlier versions are vulnerable. It is not easily possible to work around this issue without upgrading.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@podium/layout4.6.110GHSA-3hjg-vc7r-rcrw
npm@podium/proxy4.2.74GHSA-3hjg-vc7r-rcrw

Affected products (as reported)

VendorProductVersions
podium-lib proxy < 4.6.110< 4.2.74

Weakness: CWE-248 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References