Vulnerability · Published Apr 4, 2022 · Assigned by GitHub_M
CVE-2022-24814Cross-site Scripting in Directus
High 8.8
In plain English
A high-severity cross-site scripting in directus from directus. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 64% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Directus is a real-time API and App dashboard for managing SQL database content. Prior to version 9.7.0, unauthorized JavaScript (JS) can be executed by inserting an iframe into the rich text html interface that links to a file uploaded HTML file that loads another uploaded JS file in its script tag. This satisfies the regular content security policy header, which in turn allows the file to run any arbitrary JS. This issue was resolved in version 9.7.0. As a workaround, disable the live embed in the what-you-see-is-what-you-get by adding `{ "media_live_embeds": false }` to the _Options Overrides_ option of the Rich Text HTML interface.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | directus | 9.7.0 | GHSA-xmjj-3c76-5w84 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://github.com/directus/directus/security/advisories/GHSA-xmjj-3c76-5w84 x_refsource_CONFIRM
- https://github.com/directus/directus/pull/12020 x_refsource_MISC
- https://github.com/directus/directus/releases/tag/v9.7.0 x_refsource_MISC