Vulnerability · Published Mar 21, 2022 · Assigned by GitHub_M
CVE-2022-24775Improper Input Validation in guzzlehttp/psr7
High 7.5
In plain English
A high-severity improper input validation in psr7 from guzzle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.5% (higher than 85% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)7.5High
Exploit odds (30 days)2.5%top 15.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | php-guzzlehttp-psr7 | 1.8.5-1 | DEBIAN-CVE-2022-24775 |
| Debian:13 | php-guzzlehttp-psr7 | 1.8.5-1 | DEBIAN-CVE-2022-24775 |
| Debian:14 | php-guzzlehttp-psr7 | 1.8.5-1 | DEBIAN-CVE-2022-24775 |
| Packagist | drupal/core | 9.2.16, 9.3.9 | DRUPAL-CORE-2022-006 |
| Packagist | guzzlehttp/psr7 | 1.8.4 | GHSA-q7rv-6hp3-vh96 |
| Packagist | guzzlehttp/psr7 | 2.1.1 | GHSA-q7rv-6hp3-vh96 |
Affected products (as reported)
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
References
- https://github.com/guzzle/psr7/security/advisories/GHSA-q7rv-6hp3-vh96 x_refsource_CONFIRM
- https://github.com/guzzle/psr7/pull/485/commits/e55afaa3fc138c89adf3b55a8ba20dc60d17f1f1 x_refsource_MISC
- https://github.com/guzzle/psr7/pull/486/commits/9a96d9db668b485361ed9de7b5bf1e54895df1dc x_refsource_MISC
- https://www.drupal.org/sa-core-2022-006 x_refsource_CONFIRM