Vulnerability · Published Mar 21, 2022 · Assigned by GitHub_M

CVE-2022-24766Insufficient Protection against HTTP Request Smuggling in mitmproxy

Critical 9.8

In plain English

A critical-severity security flaw in mitmproxy from mitmproxy. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)1.6%top 23.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

mitmproxy is an interactive, SSL/TLS-capable intercepting proxy. In mitmproxy 7.0.4 and below, a malicious client or server is able to perform HTTP request smuggling attacks through mitmproxy. This means that a malicious client/server could smuggle a request/response through mitmproxy as part of another request/response's HTTP message body. While mitmproxy would only see one request, the target server would see multiple requests. A smuggled request is still captured as part of another request's body, but it does not appear in the request list and does not go through the usual mitmproxy event hooks, where users may have implemented custom access control checks or input sanitization. Unless mitmproxy is used to protect an HTTP/1 service, no action is required. The vulnerability has been fixed in mitmproxy 8.0.0 and above. There are currently no known workarounds.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12mitmproxy8.1.1-1DEBIAN-CVE-2022-24766
Debian:14mitmproxy8.1.1-1DEBIAN-CVE-2022-24766
PyPImitmproxy8.0.0GHSA-gcx2-gvj7-pxv3
PyPImitmproxy8.0.0PYSEC-2022-170
Ubuntu:22.04:LTSmitmproxyno fix listedUBUNTU-CVE-2022-24766
Ubuntu:24.04:LTSmitmproxyno fix listedUBUNTU-CVE-2022-24766
Ubuntu:25.10mitmproxyno fix listedUBUNTU-CVE-2022-24766
Ubuntu:26.04:LTSmitmproxyno fix listedUBUNTU-CVE-2022-24766
Ubuntu:26.10mitmproxyno fix listedUBUNTU-CVE-2022-24766

Affected products (as reported)

VendorProductVersions
mitmproxy mitmproxy <= 7.0.4

Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References