Vulnerability · Published Mar 17, 2022 · Assigned by GitHub_M

CVE-2022-24761HTTP Request Smuggling in waitress

High 7.5

In plain English

A high-severity security flaw in waitress from Pylons. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.8% (higher than 78% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.8%top 21.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Waitress is a Web Server Gateway Interface server for Python 2 and 3. When using Waitress versions 2.1.0 and prior behind a proxy that does not properly validate the incoming HTTP request matches the RFC7230 standard, Waitress and the frontend proxy may disagree on where one request starts and where it ends. This would allow requests to be smuggled via the front-end proxy to waitress and later behavior. There are two classes of vulnerability that may lead to request smuggling that are addressed by this advisory: The use of Python's `int()` to parse strings into integers, leading to `+10` to be parsed as `10`, or `0x01` to be parsed as `1`, where as the standard specifies that the string should contain only digits or hex digits; and Waitress does not support chunk extensions, however it was discarding them without validating that they did not contain illegal characters. This vulnerability has been patched in Waitress 2.1.1. A workaround is available. When deploying a proxy in front of waitress, turning on any and all functionality to make sure that the request matches the RFC7230 standard. Certain proxy servers may not have this functionality though and users are encouraged to upgrade to the latest version of waitress instead.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12waitress2.1.1-1DEBIAN-CVE-2022-24761
Debian:13waitress2.1.1-1DEBIAN-CVE-2022-24761
Debian:14waitress2.1.1-1DEBIAN-CVE-2022-24761
PyPIwaitress2.1.1GHSA-4f7p-27jc-3c36
PyPIwaitress2.1.1PYSEC-2022-169
Ubuntu:22.04:LTSwaitress1.4.4-1.1ubuntu1UBUNTU-CVE-2022-24761

Affected products (as reported)

VendorProductVersions
Pylons waitress < 2.1.1

Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References