Vulnerability · Published Mar 14, 2022 · Assigned by GitHub_M

CVE-2022-24743Insufficient Session Expiration in Sylius

High 7.1

In plain English

A high-severity security flaw in Sylius from Sylius. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.1High
Exploit odds (30 days)1.3%top 30.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Sylius is an open source eCommerce platform. Prior to versions 1.10.11 and 1.11.2, the reset password token was not set to null after the password was changed. The same token could be used several times, which could result in leak of the existing token and unauthorized password change. The issue is fixed in versions 1.10.11 and 1.11.2. As a workaround, overwrite the `Sylius\Bundle\ApiBundle\CommandHandler\ResetPasswordHandler` class with code provided by the maintainers and register it in a container. More information about this workaround is available in the GitHub Security Advisory.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistsylius/sylius1.10.11GHSA-mf3v-f2qq-pf9g
Packagistsylius/sylius1.11.2GHSA-mf3v-f2qq-pf9g

Affected products (as reported)

VendorProductVersions
Sylius Sylius < 1.10.11>= 1.11.0, < 1.11.2

Weakness: CWE-613 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N

References