Vulnerability · Published Mar 9, 2022 · Assigned by GitHub_M
CVE-2022-24741High memory usage in Nextcloud server
Low 3.5
In plain English
A low-severity uncontrolled resource consumption in security-advisories from nextcloud. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities).
Official description
Nextcloud server is an open source, self hosted cloud style services platform. In affected versions an attacker can cause a denial of service by uploading specially crafted files which will cause the server to allocate too much memory / CPU. It is recommended that the Nextcloud Server is upgraded to 21.0.8 , 22.2.4 or 23.0.1. Users unable to upgrade should disable preview generation with the `'enable_previews'` config flag.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | security-advisories | < 21.0.8>= 22.0.0, < 22.2.4>= 23.0.0, < 23.0.1 |
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-jf3h-xf4q-mh89 x_refsource_CONFIRM
- https://github.com/nextcloud/server/pull/30291 x_refsource_MISC
- https://hackerone.com/reports/1261225 x_refsource_MISC
- GLSA-202208-17 vendor-advisory, x_refsource_GENTOO