Vulnerability · Published Mar 16, 2022 · Assigned by GitHub_M

CVE-2022-24728Cross-site Scripting in CKEditor4

Medium 5.4

In plain English

A medium-severity cross-site scripting in ckeditor4 from ckeditor. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)1.2%top 31.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4 prior to version 4.18.0. The vulnerability allows someone to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. This problem has been patched in version 4.18.0. There are currently no known workarounds.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ckeditor4.19.0+dfsg-1DEBIAN-CVE-2022-24728
Debian:12ckeditor3no fix listedDEBIAN-CVE-2022-24728
Packagistdrupal/core9.2.15, 9.3.8DRUPAL-CORE-2022-005
Ubuntu:22.04:LTSckeditor3no fix listedUBUNTU-CVE-2022-24728
Ubuntu:24.04:LTSckeditor3no fix listedUBUNTU-CVE-2022-24728
Ubuntu:22.04:LTSldap-account-managerno fix listedUBUNTU-CVE-2022-24728
Ubuntu:24.04:LTSldap-account-managerno fix listedUBUNTU-CVE-2022-24728
Ubuntu:25.10ldap-account-managerno fix listedUBUNTU-CVE-2022-24728
Ubuntu:26.04:LTSldap-account-managerno fix listedUBUNTU-CVE-2022-24728
Ubuntu:22.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2022-24728
Ubuntu:24.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2022-24728
Ubuntu:25.10request-tracker4no fix listedUBUNTU-CVE-2022-24728
Ubuntu:26.04:LTSrequest-tracker4no fix listedUBUNTU-CVE-2022-24728
npmckeditor44.18.0GHSA-4fc4-4p5g-6w89

Affected products (as reported)

VendorProductVersions
ckeditor ckeditor4 < 4.18.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

References