Vulnerability · Published Feb 24, 2022 · Assigned by GitHub_M
CVE-2022-24709Cross site scripting in @awsui/components-react
High 8.8
In plain English
A high-severity cross-site scripting in awsui-documentation from aws. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
@awsui/components-react is the main AWS UI package which contains React components, with TypeScript definitions designed for user interface development. Multiple components in versions before 3.0.367 have been found to not properly neutralize user input and may allow for javascript injection. Users are advised to upgrade to version 3.0.367 or later. There are no known workarounds for this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @awsui/components-react | 3.0.367 | GHSA-mf22-92pm-m8p8 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| aws | awsui-documentation | < 3.0.367 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://github.com/aws/awsui-documentation/security/advisories/GHSA-mf22-92pm-m8p8 x_refsource_CONFIRM
- https://www.npmjs.com/package/%40awsui/components-react x_refsource_MISC