Vulnerability · Published Mar 3, 2022 · Assigned by GitHub_M

CVE-2022-23648Insecure handling of image volumes in containerd CRI plugin

High 7.5

In plain English

A high-severity information exposure in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 27.4% (higher than 98% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)27.4%top 1.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling1Public PoC

Official description

containerd is a container runtime available as a daemon for Linux and Windows. A bug was found in containerd prior to versions 1.6.1, 1.5.10, and 1.14.12 where containers launched through containerd’s CRI implementation on Linux with a specially-crafted image configuration could gain access to read-only copies of arbitrary files and directories on the host. This may bypass any policy-based enforcement on container setup (including a Kubernetes Pod Security Policy) and expose potentially sensitive information. Kubernetes and crictl can both be configured to use containerd’s CRI implementation. This bug has been fixed in containerd 1.6.1, 1.5.10, and 1.4.12. Users should update to these versions to resolve the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20containerd1.6.1-r0ALPINE-CVE-2022-23648
Alpine:v3.21containerd1.6.1-r0ALPINE-CVE-2022-23648
Alpine:v3.22containerd1.6.1-r0ALPINE-CVE-2022-23648
Alpine:v3.23containerd1.6.1-r0ALPINE-CVE-2022-23648
Alpine:v3.24containerd1.6.1-r0ALPINE-CVE-2022-23648
Debian:12containerd1.6.1~ds1-1DEBIAN-CVE-2022-23648
Debian:13containerd1.6.1~ds1-1DEBIAN-CVE-2022-23648
Debian:14containerd1.6.1~ds1-1DEBIAN-CVE-2022-23648
Gogithub.com/containerd/containerd1.5.10GHSA-crp2-qrr5-8pq7
Gogithub.com/containerd/containerd1.4.13GHSA-crp2-qrr5-8pq7
Gogithub.com/containerd/containerd1.6.1GHSA-crp2-qrr5-8pq7
Gogithub.com/containerd/containerd1.4.13, 1.5.10, 1.6.1GO-2022-0344
Ubuntu:22.04:LTScontainerd1.5.9-0ubuntu2UBUNTU-CVE-2022-23648

Affected products (as reported)

VendorProductVersions
containerd containerd < 1.4.13>= 1.5.0, < 1.5.10>= 1.6.0, < 1.6.1

Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References