Vulnerability · Published Feb 18, 2022 · Assigned by GitHub_M

CVE-2022-23647Cross-site Scripting in Prism

High 7.5

In plain English

A high-severity cross-site scripting in prism from PrismJS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 73% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.4%top 27.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Prism is a syntax highlighting library. Starting with version 1.14.0 and prior to version 1.27.0, Prism's command line plugin can be used by attackers to achieve a cross-site scripting attack. The command line plugin did not properly escape its output, leading to the input text being inserted into the DOM as HTML code. Server-side usage of Prism is not impacted. Websites that do not use the Command Line plugin are also not impacted. This bug has been fixed in v1.27.0. As a workaround, do not use the command line plugin on untrusted inputs, or sanitize all code blocks (remove all HTML code text) from all code blocks that use the command line plugin.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-prismjs1.27.0+dfsg+~1.26.0-1DEBIAN-CVE-2022-23647
Debian:13node-prismjs1.27.0+dfsg+~1.26.0-1DEBIAN-CVE-2022-23647
Debian:14node-prismjs1.27.0+dfsg+~1.26.0-1DEBIAN-CVE-2022-23647
Ubuntu:22.04:LTSnode-prismjsno fix listedUBUNTU-CVE-2022-23647
npmprismjs1.27.0GHSA-3949-f494-cm99

Affected products (as reported)

VendorProductVersions
PrismJS prism >= 1.14.0, < 1.27.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:L

References