Vulnerability · Published Feb 16, 2022 · Assigned by GitHub_M
CVE-2022-23644Server-side request forgery in BookWyrm
High 8.8
In plain English
A high-severity server-side request forgery in bookwyrm from bookwyrm-social. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities).
Official description
BookWyrm is a decentralized social network for tracking reading habits and reviewing books. The functionality to load a cover via url is vulnerable to a server-side request forgery attack. Any BookWyrm instance running a version prior to v0.3.0 is susceptible to attack from a logged-in user. The problem has been patched and administrators should upgrade to version 0.3.0 As a workaround, BookWyrm instances can close registration and limit members to trusted individuals.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| bookwyrm-social | bookwyrm | < 0.3.0 |
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H