Vulnerability · Published Feb 14, 2022 · Assigned by GitHub_M

CVE-2022-23638Cross-site Scripting in svg-sanitizer

Medium 6.2

In plain English

A medium-severity cross-site scripting in svg-sanitizer from darylldoyle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.2Medium
Exploit odds (30 days)0.7%top 47.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the `svg-sanitizer` library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistenshrined/svg-sanitize0.15.0GHSA-fqx8-v33p-4qcc
Ubuntu:22.04:LTSspipno fix listedUBUNTU-CVE-2022-23638
Ubuntu:24.04:LTSspipno fix listedUBUNTU-CVE-2022-23638
Ubuntu:25.10spipno fix listedUBUNTU-CVE-2022-23638
Ubuntu:26.04:LTSspipno fix listedUBUNTU-CVE-2022-23638
Ubuntu:26.10spipno fix listedUBUNTU-CVE-2022-23638

Affected products (as reported)

VendorProductVersions
darylldoyle svg-sanitizer < 0.15.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References