Vulnerability · Published Dec 14, 2022 · Assigned by GitHub_M

CVE-2022-23503TYPO3 vulnerable to Arbitrary Code Execution via Form Framework

High 7.5

In plain English

A high-severity code injection in typo3 from TYPO3. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 58% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.8%top 42.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

TYPO3 is an open source PHP based web content management system. Versions prior to 8.7.49, 9.5.38, 10.4.33, 11.5.20, and 12.1.1 are vulnerable to Code Injection. Due to the lack of separating user-submitted data from the internal configuration in the Form Designer backend module, it is possible to inject code instructions to be processed and executed via TypoScript as PHP code. The existence of individual TypoScript instructions for a particular form item and a valid backend user account with access to the form module are needed to exploit this vulnerability. This issue is patched in versions 8.7.49 ELTS, 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagisttypo3/cms10.4.33GHSA-c5wx-6c2c-f7rm
Packagisttypo3/cms11.5.20GHSA-c5wx-6c2c-f7rm
Packagisttypo3/cms12.1.1GHSA-c5wx-6c2c-f7rm
Packagisttypo3/cms-core11.5.20GHSA-c5wx-6c2c-f7rm
Packagisttypo3/cms-core8.7.49GHSA-c5wx-6c2c-f7rm
Packagisttypo3/cms-core12.1.1GHSA-c5wx-6c2c-f7rm
Packagisttypo3/cms-core9.5.38GHSA-c5wx-6c2c-f7rm
Packagisttypo3/cms-core10.4.33GHSA-c5wx-6c2c-f7rm

Affected products (as reported)

VendorProductVersions
TYPO3 typo3 >= 8.0.0, < 8.7.49>= 9.0.0, < 9.5.38>= 10.0.0, < 10.4.33>= 11.0.0, < 11.5.20>= 12.0.0, < 12.1.1

Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

References