Vulnerability · Published Dec 14, 2022 · Assigned by GitHub_M
CVE-2022-23500TYPO3 subject to Uncontrolled Recursion resulting in Denial of Service
Medium 5.9
In plain English
A medium-severity security flaw in typo3 from TYPO3. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
TYPO3 is an open source PHP based web content management system. In versions prior to 9.5.38, 10.4.33, 11.5.20, and 12.1.1, requesting invalid or non-existing resources via HTTP triggers the page error handler, which again could retrieve content to be shown as an error message from another page. This leads to a scenario in which the application is calling itself recursively - amplifying the impact of the initial attack until the limits of the web server are exceeded. This vulnerability is very similar, but not identical, to the one described in CVE-2021-21359. This issue is patched in versions 9.5.38 ELTS, 10.4.33, 11.5.20 or 12.1.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | typo3/cms | 10.4.33 | GHSA-8c28-5mp7-v24h |
| Packagist | typo3/cms | 11.5.20 | GHSA-8c28-5mp7-v24h |
| Packagist | typo3/cms-core | 9.5.38 | GHSA-8c28-5mp7-v24h |
| Packagist | typo3/cms-core | 10.4.33 | GHSA-8c28-5mp7-v24h |
| Packagist | typo3/cms-core | 11.5.20 | GHSA-8c28-5mp7-v24h |
Affected products (as reported)
Weakness: CWE-674 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/TYPO3/typo3/security/advisories/GHSA-8c28-5mp7-v24h x_refsource_CONFIRM