Vulnerability · Published Dec 8, 2022 · Assigned by GitHub_M

CVE-2022-23496A crafted list can trigger a ArrayIndexOutOfBoundsException in Yauaa

High 7.5

In plain English

A high-severity security flaw in yauaa from nielsbasjes. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.8%top 43.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Yet Another UserAgent Analyzer (Yauaa) is a java library that tries to parse and analyze the useragent string and extract as many relevant attributes as possible. Applications using the Client Hints analysis feature introduced with 7.0.0 can crash because the Yauaa library throws an ArrayIndexOutOfBoundsException. If uncaught the exception will result in a program crash. Applications that do not use this feature are not affected. Users are advised to upgrade to version 7.9.0. Users unable to upgrade may catch and discard any ArrayIndexOutOfBoundsException thrown by the Yauaa library.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavennl.basjes.parse.useragent:yauaa7.9.0GHSA-c4pm-63cg-9j7h
Mavennl.basjes.parse.useragent:yauaa-beam7.9.0GHSA-c4pm-63cg-9j7h
Mavennl.basjes.parse.useragent:yauaa-beam-sql7.9.0GHSA-c4pm-63cg-9j7h
Mavennl.basjes.parse.useragent:yauaa-drill7.9.0GHSA-c4pm-63cg-9j7h
Mavennl.basjes.parse.useragent:yauaa-elasticsearch7.9.0GHSA-c4pm-63cg-9j7h
Mavennl.basjes.parse.useragent:yauaa-elasticsearch-87.9.0GHSA-c4pm-63cg-9j7h
Mavennl.basjes.parse.useragent:yauaa-flink7.9.0GHSA-c4pm-63cg-9j7h
Mavennl.basjes.parse.useragent:yauaa-flink-table7.9.0GHSA-c4pm-63cg-9j7h
Mavennl.basjes.parse.useragent:yauaa-hive7.9.0GHSA-c4pm-63cg-9j7h
Mavennl.basjes.parse.useragent:yauaa-logparser7.9.0GHSA-c4pm-63cg-9j7h
Mavennl.basjes.parse.useragent:yauaa-snowflake7.9.0GHSA-c4pm-63cg-9j7h
Mavennl.basjes.parse.useragent:yauaa-trino7.9.0GHSA-c4pm-63cg-9j7h

Affected products (as reported)

VendorProductVersions
nielsbasjes yauaa >= 7.0.0, < 7.9.0

Weakness: CWE-755 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References