Vulnerability · Published Dec 10, 2022 · Assigned by GitHub_M

CVE-2022-23485Invite code reuse via cookie manipulation in sentry

Medium 6.4

In plain English

A medium-severity privilege mismanagement in sentry from getsentry. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.4Medium
Exploit odds (30 days)0.5%top 60.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Sentry is an error tracking and performance monitoring platform. In versions of the sentry python library prior to 22.11.0 an attacker with a known valid invite link could manipulate a cookie to allow the same invite link to be reused on multiple accounts when joining an organization. As a result an attacker with a valid invite link can create multiple users and join an organization they may not have been originally invited to. This issue was patched in version 22.11.0. Sentry SaaS customers do not need to take action. Self-hosted Sentry installs on systems which can not upgrade can disable the invite functionality until they are ready to deploy the patched version by editing their `sentry.conf.py` file (usually located at `~/.sentry/`).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIsentry22.11.0GHSA-jv85-mqxj-3f9j
PyPIsentry22.11.0PYSEC-2022-43011
Ubuntu:22.04:LTSsentry-pythonno fix listedUBUNTU-CVE-2022-23485
Ubuntu:24.04:LTSsentry-pythonno fix listedUBUNTU-CVE-2022-23485
Ubuntu:25.10sentry-pythonno fix listedUBUNTU-CVE-2022-23485
Ubuntu:26.04:LTSsentry-pythonno fix listedUBUNTU-CVE-2022-23485
Ubuntu:26.10sentry-pythonno fix listedUBUNTU-CVE-2022-23485

Affected products (as reported)

VendorProductVersions
getsentry sentry >= 20.6.0, < 22.11.0

Weakness: CWE-269, CWE-284 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:L

References