Vulnerability · Published Jan 26, 2022 · Assigned by GitHub_M

CVE-2022-21686Server Side Twig Template Injection in PrestaShop

Critical 9.0

In plain English

A critical-severity code injection in PrestaShop from PrestaShop. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.8% (higher than 78% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.0Critical
Exploit odds (30 days)1.8%top 21.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

PrestaShop is an Open Source e-commerce platform. Starting with version 1.7.0.0 and ending with version 1.7.8.3, an attacker is able to inject twig code inside the back office when using the legacy layout. The problem is fixed in version 1.7.8.3. There are no known workarounds.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistprestashop/prestashop1.7.8.3GHSA-mrq4-7ch7-2465

Affected products (as reported)

VendorProductVersions
PrestaShop PrestaShop >= 1.7.0.0, < 1.7.8.3

Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

References